Netbeans IDE

Při výuce programování se používá programovací jazyk Java ve vývojovém prostředí NetBeans IDE.

Stažení vývojového prostředí z Internetu

  1. Stáhněte si balíček obsahující integrované vývojové prostředí NetBeans IDE spolu s Java JDK ze stránek Oracle → část Java SE Development Kit (JDK) Bundles → JDK 8u60 & NetBeans 8.0.1 → Download → vyberte platformu, souhlaste s licencí
  2. Stáhněte dokumentaci Java API ze stejné stránky Oracle → Additional Resources → Java SE 8 Documentation → Download → souhlaste s licencí → Stažený zip nerozbalujte!
Pro předmět PR1 je nutné používat Javu verze 8 a výše.

Instalace vývojového prostředí ve Windows

  1. Spusťte instalátor javy spolu s netbeans a proveďte instalaci.
  2. Přesuňte zip soubor s dokumentací na vhodné místo svého disku (obsahuje dokumentaci Javy).
  3. Spusťte NetBeans a vyčkejte ustálení.
  4. Připojte dokumentaci: Tools → Java Platforms → záložka Javadoc → AddZIP/Folder → zip soubor s dokumentací → Close.

Aktivace nápovědy atributů a metod objektů

Tools → Options → Editor zatrhněte: Auto Popup Completion Window, Insert Single Proposals Automatically.

Zobrazení důležitých pohledů

Okénko struktury souborů

Otevřete pomocí: Window → Files

Okénko procesů

Otevřete pomocí: Window → Processes

Toto okno slouží k prohlížení a hlavně ukončování běžících procesů. Pokud nějakému procesu zavřete okno pro výstup tento proces dál žije a požírá systémové prostředky.

Zkratky

Netbeans poskytuje expanzi zkratek pro často užívané programové sekvence. Seznam zkratek najdete na záložce Tools → Options → Editor → Code Templates. Prohlédněte si zkratky - Abbreviations a jejich expanze, případně si zaveďte vlastní – viz doporučení dále. Tab na konci zkratky způsobí náhradu.

Vytvoření programu

Založení projektu: File → New Project → Java → Java Class Library → Next. Vyplňte Project Name a Project Location → Finish.

Vytvoření elementárního programu

Ve zvoleném projektu myší vyznačte Source Packages → New → Java Class → zadejte Class Name začínající velkým písmenem. V Package zadejte jméno balíčku z malých písmen a číslic začínající písmenem → Finish.

Ve třídě vytvořte metodu main - vstupní bod programu: použijeme expanzi zkratky psvm TAB

Spuštění programu

Myší identifikujte zdrojový program, pak Shift+F6 nebo pravým tlačítkem → Run File.

Spuštění programu s argumenty (v rámci NetBeans IDE)

Source Packages → Properties → Run → Arguments. Funguje jen při spouštění projektu. Při spouštění souboru má pole String[] args nulovou délku.

Spouštění z příkazové řádky (bez IDE):

cd \…\ProjectFolder\build\classes java p1.T1 arg1, arg2, …

  • p1.T1 - je úplné jméno spouštěné třídy,
  • arg1, arg2, … - jsou libovolné řetězy znaků oddělené mezerou.
  • Tyto argumenty jsou předány metodě main v poli args. První argument lze referencovat jako args[0].

Klávesové zkratky

Ctrl-Space dokončovaní kódu
Ctrl-F vyhledávání
F9 překlad balíku nebo souboru
F11 překlad celého projektu
F6 spuštění hlavního projektu
Shift-F6 spuštění souboru

Editorové zkratky pro psaní kódu

psvm public static void main(String[ ] args) {}
sout System.out.println(““);
St String
ife if ( ) else
sw switch case default
for cykl
fori cykl probírka pole
fore cykl probírka kolekce
forc cykl přes iterator
wh while( true) {
br break
cn continue
m static final void method() {
pu public
re return
th throws
Ex Exception
cl class
st static
bo boolean
fa false
Kompletní seznam zkratek naleznete v NetBeans IDE na záložce Help → Keyboard Shortcuts Card.
courses/b0b36pjv/tutorials/01/netbeans.txt · Last modified: 2018/02/06 08:43 (external edit)