Warning
This page is located in archive.

Brute specification

All evaluation code in BRUTE is running with python3.

In general, code is not running on a computer with GPU. However, some of the homework might be running on a physical computer with GPU available. In such case, there will be a note about it in an HW assignment, torch.cuda.is_available() = True and such GPU will be NVIDIA GTX 1080 Ti (11GB VRAM).

Versions of available Python packages are listed below. The versions listed will not change during the run of the course.

If you are missing some packages, we might include it, however, there are no guarantees. Email jasekota@fel.cvut.cz for such requests.

Python and packages versions

teacher@brute:~$ python3
Python 3.7.3 (default, Apr  3 2019, 05:39:12) 
[GCC 8.3.0] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>>
teacher@brute:~$ pip3 freeze
asn1crypto==0.24.0
attrs==18.2.0
cloudpickle==1.2.1
cryptography==2.6.1
cycler==0.10.0
decorator==4.3.0
entrypoints==0.3
future==0.17.1
gym==0.14.0
keyring==17.1.1
keyrings.alt==3.1.1
kiwisolver==1.0.1
matplotlib==3.0.2
numpy==1.16.2
olefile==0.46
Pillow==5.4.1
psutil==5.5.1
pycrypto==2.6.1
pyglet==1.3.2
PyGObject==3.30.4
pyparsing==2.2.0
python-dateutil==2.7.3
python-magic==0.4.16
pyxdg==0.25
PyYAML==3.13
scipy==1.1.0
SecretStorage==2.3.1
six==1.12.0
stopit==1.1.2
torch==1.1.0
torchvision==0.3.0
courses/b3b33vir/resources/brute_spec/start.txt ยท Last modified: 2019/10/11 09:38 by jasekota